Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1996 Olds Ciera Dash Brake Light Fix
#1
In case anyone stumbles across this and remembers my post on the original a-body.net forum about my ABS and red brake dash light being on even though there was nothing wrong with the brake system, I wanted to give an update.

It turns out one of the fusible link wires that attach to the battery's positive terminal was broken. (I think there are three of them). I connected the broken wire to the battery and *bam* both lights on the dash went off.

It looks like it was just a random electrical issue. I forget the username but I think the user Keith said that it might be one of those wires.. well, he was right.

My car floated around sitting for a year due to not being able to pass inspection until I decided to go back and tinker with that broken wire.

So anyway. Thanks for the info! Hopefully this might help someone in the future.
Reply
#2
Keith is a great fella to have remotely diagnose issues! Glad you got it resolved. I have had my abs unplugged for years, the bulb finally burned out. Yay!
Reply
#3
(06-22-2024, 08:26 AM)Doc Salvage Wrote: Keith is a great fella to have remotely diagnose issues!  Glad you got it resolved.  I have had my abs unplugged for years, the bulb finally burned out.  Yay!

I need to fix my ABS, well, not the ABS specifically. My issue is the actual hydraulic unit in the all-in-one Teves unit. The ABS part functions fine, but the pedal goes to the floor the actual brake light comes on and off. I'm trying to rebuild or find a replacement hydro section of that teves unit.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)